PDA

View Full Version : Can't print to a HP Laserjet 5si


blujely37
03-20-2008, 07:22 PM
Hello,
I am having trouble printing from preps to a specific printer. We just switched to macs in the last few weeks and i tried to print to our HP Laserjet 5si for the first time today from Preps. We print small folding dummies on our HP Laserjet 5si. All the other programs will print to this printer and i never had a problem with this out of Windows. I made sure i had the right ppd in Prep's ppd folder also. When I print to the printer the file seems to make it there fine and the light begins flashing on the printer like it is receiving data but then just stops flashing and the file disappears and there is nothing in the log to show what happened. If anyone has any ideas on what could be wrong please let me know.

Natalie
03-20-2008, 07:48 PM
Perhaps the file size is too large. Do you print a pdf from Preps? If so, try reducing the file size.

robert.hammen
03-20-2008, 08:20 PM
We still use HP LaserJet 5Si's... no problems (we're using the MX PostScript versions - are you?).

Sounds like a PostScript error is being generated... check all of your settings/options.

If nothing else...print to a PDF, open it up in Preview or Acrobat and try printing to the 5Si again...

--Robert

blujely37
03-22-2008, 03:57 PM
I have checked all my settings over and over again and we are using the same driver that you mentioned. I can print to ps distill to pdf and then print from acrobat to the printer just fine and every other program print to the printer just fine. It is only when I print from Preps that the problem happens. I also think it looks like a driver problem so i have tried every driver i could find for this printer just to see if it made any difference and it doesn't. I can't think of anything else it could be besides a postscript error because it actually makes it to the printer but then just disappears.
Thanks

blujely37
03-24-2008, 01:23 PM
Robert, could you please attach the driver you are using for this printer to a post so i can try the exact one that you are using to see if that will work. Also what version of Mac OS X are you using?

robert.hammen
03-24-2008, 04:31 PM
We're on Mac OS X 10.4.11 in production.

Here's the info from the beginning of the PPD file (I copied it to the desktop an un-gzip'ed it)

*% PPD File Version Information
*FormatVersion: "4.3"
*FileVersion: "4.0.0.080"
*LanguageEncoding: ISOLatin1
*LanguageVersion: English
*cupsLanguages: "da de es fi fr it nl nb pt sv"
*Manufacturer: "HP"
*PCFileName: "HPLJ5SI1.PPD"
*APDialogExtension: "/Library/Printers/hp/PDEs/hpPostScriptPDE.plugin"
*HPPDEPanel: "HPColorOptionsPanel"
*HPPDEPanel: "HPEdgeToEdge"
*HPPDEPanel: "HPFinishingPanel"
*HPPDEPanel: "HPImagingOptions"
*HPPDEController ImageQuality: "ImageQualityLaserJets"
*HPPDEPanel: "HPProofAndPrint"
*APPrinterIconPath: "/Library/Printers/hp/Icons/HP LaserJet 5Si.icns"

*% Product Version Information
*Product: "(HP LaserJet 5Si)"
*PSVersion: "(2014.108) 1"
*ModelName: "HP LaserJet 5Si"
*ShortNickName: "HP LaserJet 5Si/5Si MX PS"
*NickName: "HP LaserJet 5Si/5Si MX PostScript"



Below is the contents of the AraxiPreps:Printers:<myprintername>:printer.ppd file:

*PPD-Adobe: "4.0"
*%__SSi_BEGIN_USER_CHANGES__
*%__SSi_END_USER_CHANGES__
*SSiSetting IO: "98"
*SSiSetting IO.Sync: "False"
*SSiSetting PPD: hp5si
*SSiSetting OPIColor: "False"
*SSiSetting ReverseOrder: "False"
*DefaultPageSize: Letter
*DefaultPageRegion: Letter
*SSiAlignPageSize Letter: "0.00000 0.00000"
*NickName: HP LaserJet 5Si
*DefaultInputSlot: Tray1
*DefaultResolution: 300dpi
*ScreenFreq: "85.00000"
*ScreenAngle: "45.00000"
*DefaultScreenProc: RIP-Default
*DefaultSSiJobNotes: Customer
*DefaultMediaType: None
*DefaultDuplex: DuplexTumble
*% eof

Send me a PM with your email address if you can't get this figured out, and perhaps I can help off-line.

--Robert

blujely37
03-24-2008, 06:57 PM
Okay I don't have that version of the driver. The version i am currently using is 4.3***. I did some more testing and happen to think to try to print a mockup and that works it is only when I try to print something to it with text (or our fonts) in it. I am also finding out that postscript fonts do not work so well with Macs and in some cases they don't work at all. The majority of our files are created in house and have mostly post script fonts in them. So much for the guys on the design end of our work wanting to switch completely to Macs all at once and take our PC's away with nothing to fall back on.
So now I know that it must be a postscript font issue. Do you have any ideas as to why?

blujely37
03-26-2008, 02:48 PM
Thank you for your help. We actually have font doctor but it came up with no errors. I have fixed the problem though. I forgot to check one thing when I set preps up on the Mac and that was the configuration file for the profile I was using to print to the 5si. The postscript level was set to 3 and the 5si can't handle lv3 postscript so I changed it to level 2 and now it works. Sad thing is I knew that, I had just forgotten about it because it had been so long since I had to mess with the config files.
Thanks again.

blujely37
04-08-2008, 03:38 PM
Okay, I had it working. After changing the postscript level setting in the config file for the profile it worked for about a week. Then last week it stopped working. I couldn't get it to work again so I tried uninstalling the printer form my computer and reinstalling it. That fixed the problem also...for about another week. Now today I can't print to it again the file gets to the printer and crashes. No error code or anything. I went back checked to make sure the config file was still set to lv2 and it was. I tried uninstalling the printer and reinstalling it again and that did not work either.
I still believe it is a postscript issue because i can print to it form all of my other programs and I can print a test page from preps to the printer. I have checked the whole config file and i can't see anything set wrong in it.
Robert, Is there any way you could send me the config file for the profile you use to print to the 5si so I can cross reference mine to yours and just see if it might be a setting in the config file?
Thanks

robin.horn
04-10-2008, 01:06 AM
Have you tried clearing the Font Caches on the workstation?

Font cache corruption is a fairly common problem in Mac OS X. The utility that we use to do that is called FontNuke (currently at version 1.1.5) which you should be able to find with a Google search.

If this fixes the problem, then you probably have duplicate fonts in your system (Helvetica is the likely culprit).